ORIGIN

HDU-1562 Guess the number

ACM 1 mins225 words

Guess the number

Happy new year to everybody!
Now, I want you to guess a minimum number x betwwn 1000 and 9999 to let
(1) x % a = 0;
(2) (x+1) % b = 0;
(3) (x+2) % c = 0;
and a, b, c are integers between 1 and 100.
Given a,b,c, tell me what is the number of x ?

Input

The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.

Output

For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output “Impossible”.

Sample Input

1
2
3
2
44 38 49
25 56 3

Sample Output

1
2
Impossible
2575

Analysis

Just loop and calculate violently.

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include<bits/stdc++.h>

using namespace std;

int main() {
int t, a, b, c, i;
cin >> t;
while(t --) {
cin >> a >> b >> c;
i = 1000;
while(i < 10000) {
if(i % a == 0 and (i + 1) % b == 0 and (i + 2) % c == 0) {
cout << i << endl;
break;
}
i ++;
}
if(i > 9999) cout << "Impossible" << endl;
}
return 0;
}
TOP
COMMENT
  • ABOUT
  • |
o_oyao
  The Jigsaw puzzle is incomplete with even one missing piece. And I want to be the last piece to make the puzzle complete.
Like my post?
Default QR Code
made with ❤️ by o_oyao
©o_oyao 2019-2024

|