ORIGIN

HDU-1040 As Easy As A+B

ACM 2 mins354 words

As Easy As A+B

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

1
2
3
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output

1
2
1 2 3
1 2 3 4 5 6 7 8 9

Analysis

This is a sorting problem, you can either use quick sort or bubble sort or other sorts.

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include<iostream>

using namespace std;

int a[10000];

void quick_sort(int a[], int start, int end) {
if(start >= end) return ;
int l = start, r = end;
int pivot = a[(end + start) / 2];
while(l <= r) {
while(l <= r && a[r] > pivot) r --;
while(l <= r && a[l] < pivot) l ++;
if(l <= r) swap(a[l ++], a[r --]);
}
quick_sort(a, start, r);
quick_sort(a, l, end);
}
int main() {
int t;
cin >> t;
while(t --) {
int n;
cin >> n;
for(int i = 0; i < n; i ++) {
cin >> a[i];
}
quick_sort(a, 0, n - 1);
for(int i = 0; i < n; i ++) {
if(i == n - 1) cout << a[i] << endl;
else cout << a[i] << " ";
}
}
return 0;
}
TOP
COMMENT
  • ABOUT
  • |
o_oyao
  The Jigsaw puzzle is incomplete with even one missing piece. And I want to be the last piece to make the puzzle complete.
Like my post?
Default QR Code
made with ❤️ by o_oyao
©o_oyao 2019-2024

|