ORIGIN

HDU-1008 Elevator

ACM 1 mins268 words

Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1
2
3
1 2
3 2 3 1
0

Sample Output

1
2
17
41

Analysis

This is an easy problem and you just need to stimulate the hole process.

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include<bits/stdc++.h>

using namespace std;

int main() {
int n;
while(cin >> n and n) {
int pre = 0, now = 0, dif, ans = 0;
for(int i = 0; i < n; i ++) {
cin >> now;
dif = now - pre;
if(dif > 0)
ans += dif * 6 + 5;
else ans += dif * (-4) + 5;
pre = now;
}
cout << ans << endl;
}
return 0;
}
TOP
COMMENT
  • ABOUT
  • |
o_oyao
  The Jigsaw puzzle is incomplete with even one missing piece. And I want to be the last piece to make the puzzle complete.
Like my post?
Default QR Code
made with ❤️ by o_oyao
©o_oyao 2019-2024

|